You are here

Minimum system requirements for Field and Field Mobile

Here's what you need to run Field and Field Mobile.

Use Field on the desktop

You can use Field with the same operating systems and browsers as Aconex.

The recommendations below are for Field Mobile app only

Use Field Mobile on iOS

We support Field version 5.1.0 and above. Download the latest version here.

Field Mobile runs on iPad and iPad Mini and iPhone devices and above running (IOS 10, 11). 

At least 5 GB free storage space is recommended. 

We will deprecate support for OS 8/9. 

Use Field Mobile on Android

We support Field version 5.1.0 and above. Download the latest version here.

Field Mobile runs on phones and tablets:

  • running Android Version 5.1 (Lollipop) and above

  • Recommended: Minimum 2 GB RAM, At least 5 GB free storage space

Users will not be blocked from using earlier app versions or installing on devices that do not meet the recommendations. But be aware that performance may be reduced.

Was this article helpful?

Thanks. A ticket has been opened with the Support Central team.