Maintenance required - Friday August 7th 10:00 pm (UTC – Coordinated Universal Time)

Support Central will be briefly offline on Friday August 7th at 10:00 pm (UTC) while we make improvements and upgrades to this site.

You are here

Create a Report Layout with the Online Editor

Design your report with the online layout editor.

After configuring the report data model, the next task is to design its layout. Layouts allow you to represent a data model in many different ways, to produce reports for various business requirements.

Report Layouts can be produced either online or offline.  This tutorial covers the online layout editor.

Create a Report Layout

  1. From the custom report tab, click the ellipsis menu for your report and select Add/Edit Layout.
add or edit layout

If your report does not yet have a layout (you have just created a Data Model), click on its title, and then click Add Layout.   

If the report already has a layout, you will be taken to the layout selection screen.  From here click Add/Edit Layout and then Add New Layout.

add or edit layout
add new layout

The layout editor will open in a new tab within your web browser.

  1. Choose a template to design your report.
  2. In this tutorial, we’ll select Blank (Portrait) to start with a blank canvas.
select blank template

From the Page Layout tab, adjust the report orientation, the paper size and configure headers and footers.

page layout tab
  1. The layout editor has three main sections:
  1. The Main Design Area.
  2. The Insert tab.
  3. The Data Source pane.
  1. The Main Design Area to drag and drop design components and data sources to build the report layout. 
design area
  1. The top toolbar containing the Insert tab, to drag and drop visual design components into the design area.  Page elements such as page break and page number can also be dropped into the layout grid or header and footer.
insert
  1. The Data Source pane containing subject areas and attributes you configured in the data model editor.  Drag and drop these into design components.
data source
  1. To begin, let’s drag and drop a layout grid to provide some space for our design components.   We recommend always starting with a layout grid to help align the various components within the report.
    When prompted enter the required number of rows and columns for your grid, or just click OK to accept the default grid of 2 x 2.
drag and drop a layout grid
  1. Double click into a cell in your grid layout to display the Layout Grid Cell tab. 
    From here you can center the alignment for dropped components, or add and remove cells.  You can do this at any time during the layout design process.
Layout Grid Cell tab

For best results, we recommend adding one design component per cell in your layout grid.  You may need to adjust the grid size accordingly.

  1. Next, click on the Insert tab and drag a design component into the grid layout.  In this example we’ll insert a Chart
    For the full list of available components, see Using Layout Components
drag a chart component
  1. Click on the component you just inserted to customize its look. 
    For example we can change the vertical bar chart to a pie chart, or change the color style altogether.
customise design component
  1. Optionally you can further customize the component from the Properties pane:
  • Appearance: Borders and padding.
  • Chart: Animation, style.
  • Chart effects: Gradient, Tilt, Depth.
  • Chart Legend: Underline, Italic, Font Family.
  • Chart Plot Area: Data Label position, Marker Shape.
  • Chart Title: Underline, Font Family.
  • Chart Label: Rotate, Separator, Font Family.
  • Chart Value: Axis Decimals & Scaling, Currency Symbol.
  • Time Series: Year, Month, Day for axis.
  • Misc: Treat Null value as zero.
chart properties pane
  1. Now we are ready to assign attributes to our chart.  Select the Data Source pane and drag the required attributes into the Chart as indicated by the ‘Drop Here’ labels:
  • Drop Value Here  -  Drag and drop the attribute for the Y-axis of the chart.
  • Drop Series Here  - Drag and drop the attribute for the X-axis of the chart.
  • Drop Label Here  - Drag and drop the attribute for grouping the X-axis data.
drop data sources

For example, let's say we want to see how our project workflows are progressing.  We'll want to see the status of all documents in our workflows, and which organization they are assigned to. 

To do this we'll:

  • Drag the Document Number attribute into the Y-axis Value (to count the number of documents)
  • Drag the Step Status attribute into the X-axis Series
  • Drag the Assigned to Organization attribute into Label (to group the data by organization)

We’ll also make sure the Document Number Value is using a Count formula, to count the number of documents for each status.

data sources dropped into the chart

Depending on the data source, you select Average, Minimum, Maximum, Count Distinct, or a custom defined formula.

  1. If required, you can apply filters to your component, by clicking on the component and clicking Filter from the top toolbar. Multiple filters can be applied to different components in your layout. For example you may want to filter this chart to only show Architectural documents.   
add a layout filter

The Value in your filter can be a number or text, but must be entered manually, so you may want to check in Aconex to make sure you’ve entered it correctly.

Now is a good time to preview your report to get an idea of how your report will look with dummy data.  Click Preview and make any changes to your layout as needed.

preview

Finalise your report layout

You’re almost done! Insert any additional components into the design area as required, and drag and drop the applicable attributes into them. 

Once that’s complete, you can Save the layout.  You'll see a 'Saved' confirmation.

saved

You can also save a copy of your layout to edit later by clicking Save As.  Use this option to create slightly different report layouts to display your data in different ways.

save as

Click Done and you can return back to Aconex to view and share your new report.

Was this article helpful?

Thanks. A ticket has been opened with the Support Central team.