You are here

What versions of Outlook can I use with Aconex for Outlook?

FAQ

Aconex for Outlook is compatible with Outlook 2007, 2010, and 2013 (32 and 64 bit). 

Any feedback?

Thanks. A ticket has been opened with the Support Central team.